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Xây dựng ngân hàng câu hỏi - Question bank 

Ngân hàng câu hỏi - Question bank là nơi lưu trữ các câu hỏi trong khóa học, giúp cho 

Thầy/Cô dễ dàng xây dựng các loại bài tập kiểm tra khác nhau. Để truy cập vào ngân hàng 

câu hỏi, khi đứng tại giao diện chi tiết khóa học Thầy/Cô chọn More → Question bank. 
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Khai báo danh mục câu hỏi 

Ngay tại giao diện của ngân hàng câu hỏi - Question bank, Thầy/Cô tùy chọn giá trị tại 

ô Questions thành Categories để di chuyển đến giao diện khai báo danh mục câu hỏi cho 

khóa học. 

 

Tại giao diện quản lý danh mục câu hỏi, Thầy/Cô nhấn vào nút Add category để khai 

báo danh mục câu hỏi. 

 

Tại giao diện Add category, cung cấp các thông tin cho danh mục câu hỏi trong khóa 

học vào các ô: 

- Parent category: Chỉ định vị trí danh mục trong khóa học. 

- Name: Tên danh mục câu hỏi. 

- Category info: Thông tin mô tả cho danh mục. 
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Kiểm tra lại các thông tin danh mục khóa học, nhấn nút Add category để lưu lại các 

thông tin đã khai báo cho danh mục câu hỏi. Lặp lại công việc trên để khởi tạo thêm nhiều danh 

mục câu hỏi cho khóa học. 
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Thêm các câu hỏi vào các danh mục câu hỏi 

Sau khi đã khởi tạo các danh mục câu hỏi cho khóa học, để bổ sung câu hỏi vào các 

danh mục vừa tạo. Thầy/Cô truy cập vào trang ngân hàng câu hỏi - Question bank tại More 

→ Question bank. 

Danh mục bài tập điền từ vào ô trống 

Trong giao diện Question bank, tùy chọn danh mục câu hỏi tại ô “Select a category” 
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Nhấn vào nút Create a new question … để lựa chọn loại câu hỏi cho danh mục câu hỏi 

trong khóa học. Trong hộp thoại tùy chọn dạng bài tập Choose a question type to add, 

Thầy/Cô tùy chọn Embedded answers (Cloze) và nhấn vào nút “Add” để khai báo thêm mới 

câu hỏi. 

 

Tại giao diện Adding an Embedded answers (Cloze) question, khai báo các thông tin cơ 

bản cho câu hỏi tại mục General: 

- Category: Vị trí danh mục câu hỏi cần thêm vào. 

- Question name: Khai báo lên cho câu hỏi. 

- Question text: Khai báo nội dung câu hỏi. 

- Question status: Trạng thái câu hỏi (Ready - Sẵn sàng, Draft - Bản nháp). 
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Lưu ý: Tại ô “Question text”, đáp án cho câu hỏi được khai báo theo mẫu 

{1:SA:%100%<đáp án>#Correct!~*#Incorrect!} trong đó: 

- 1: điểm số của đáp án. 

- SA: Kiểu câu hỏi Shorts answer (mặc định là không phân biệt chữ hoa-thường). Khai 

báo SAC để chỉ định phân biệt chữ hoa-thường cho đáp án.  

- %100%: Tỷ lệ điểm số khi trả lời đúng. 

- <đáp án>: Đán án đúng cho câu hỏi. 

- ~: Ngăn cách giữa các đáp án. 

- Correct, Incorrect: Nội dung phản hồi cho câu hỏi. 

Kiểm tra lại các nội dung và câu trả lời cho câu hỏi, nhấn nút “Save changes” để lưu lại 

các khai báo cho câu hỏi. Thực hiện các công việc trên cho các câu hỏi tiếp theo hoặc sử dụng 

tệp danh sách câu hỏi được chuẩn bị sẵn dưới dạng tệp tin XML (.xml) theo mẫu bên dưới: 
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Đứng tại giao diện khóa học, truy cập vào ngân hàng câu hỏi - Question bank và thay 

đổi giá trị trong ô “Questions” thành giá trị “Import”. 

 

Tại giao diện Import questions from file, tùy chỉnh định mạng “Moodle XML format” 

tại mục File format và tải lên tệp câu hỏi đã chuẩn bị tại ô “Import questions from file”. Nhấn 

nút “Import” để tiến hành kiểm tra và thêm câu hỏi từ tệp đã chuẩn bị. 
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Nhấn nút “Continue” để hoàn tất việc thêm câu hỏi từ tệp dữ liệu. Tùy chọn Edit → 

Preview để xem qua câu hỏi. 
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Danh mục bài tập kéo và thả đáp án 

Trong giao diện Question bank, tùy chọn danh mục câu hỏi tại ô “Select a category” 
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Nhấn vào nút “Create a new question …” để lựa chọn loại câu hỏi cho danh mục câu 

hỏi trong khóa học. Trong hộp thoại tùy chọn dạng bài tập “Choose a question type to add”, 

Thầy/Cô tùy chọn “Drag and drop into text” và nhấn vào nút “Add” để khai báo thêm mới 

câu hỏi. 

 

Tại giao diện Adding a drag and drop into text, khai báo các thông tin cho câu hỏi tại mục 

General như sau: 

- Category: Chỉ định vị trí danh mục câu hỏi. 

- Question name: Chỉ định tên dành cho câu hỏi. 

- Question text: Chỉ định nội dung cho câu hỏi và vị trí đáp án đúng. Đáp án đúng sẽ 

được viết theo cú pháp [[vị trí đáp án đúng]], vị trí các đáp án được khai báo trong mục 

Choices. 

- Question status: Trạng thái câu hỏi (Ready - Sẵn sàng, Draft - Bản nháp). 

- Default mark: Điểm số mặc định cho câu hỏi. 
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Tại mục Choices, khai báo các đáp án có thể xuất hiện trong câu hỏi. Chọn ô “Shuffle” 

để trộn các đáp án. 

 

Kiểm tra lại thông tin câu hỏi và đáp án, nhấn nút “Save changes” để lưu lại thông tin 

câu hỏi. Tùy chọn Edit → Preview để xem trước mẫu câu hỏi mới vừa khởi tạo. 



13 
 

 

Lặp lại các bước trên để khởi tạo thêm các câu hỏi khác hoặc có thể bổ sung các câu 

hỏi thông qua tệp dữ liệu mẫu có dạng XML (.xml) như hình minh họa bên dưới 
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Truy cập vào ngân hàng câu hỏi - Question bank, đổi giá trị trong ô “Questions” sang 

giá trị “Import”. Trong giao diện Import questions from file, tùy chọn “Moodle XML format” 

tại ô File format và tải lên tệp dữ liệu tại ô “Import questions from file”. 

 

Quá trình tải lên tệp dữ liệu được xử lý và hiển thị số lượng kết quả. Nhấn nút 

“Continue” để hoàn tất việc tải lên tệp dữ liệu. 
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Nhấn nút Continue để hoàn tất các bước bổ sung câu hỏi, truy cập vào ngân hàng câu 

hỏi để xem lại các câu hỏi đã bổ sung.  
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Danh mục bài tập lựa chọn đáp án từ cửa sổ 

Trong giao diện Question bank, tùy chọn danh mục câu hỏi tại ô “Select a category” 

 

Nhấn vào nút “Create a new question …” để lựa chọn loại câu hỏi cho danh mục câu 

hỏi trong khóa học. Trong hộp thoại tùy chọn dạng bài tập “Choose a question type to add”, 

Thầy/Cô tùy chọn “Select missing words” và nhấn vào nút “Add” để khai báo thêm mới câu 

hỏi. 
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Trong giao diện Adding a select missing words question, khai báo các thông tin cho 

câu hỏi tại mục General: 

- Category: Vị trí câu hỏi trong danh mục câu hỏi. 

- Question name: Khai báo tên cho câu hỏi. 

- Question text: Khai báo nội dung cho câu hỏi. Lưu ý: Đáp án cho câu hỏi sẽ khai báo 

theo cú pháp [[vị trí đáp án]], vị trí đáp án đúng sẽ được thiết lập tại mục Choice. 

- Question status: Trạng thái câu hỏi (Ready - Sẵn sàng, Draft - Bản nháp). 

- Default mark: Điểm số mặc định cho câu hỏi. 

 

Tại mục Choice, khai báo các đáp án cho câu hỏi. Tùy chọn trộn vị trí đáp án tại ô 

“Shuffle”. 
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Kiểm tra lại các thông tin và đáp án, nhấn nút “Save changes” để lưu lại các thiết lập 

khởi tạo câu hỏi. Tùy chọn Edit → Preview để xem qua trước câu hỏi đã thiết lập. 

 

Lặp lại các bước trên để khởi tạo các câu hỏi khác cho danh mục câu hỏi hoặc có thể 

sử dụng tệp dữ liệu được chuẩn bị sẵn dưới dạng XML (.xml) theo mẫu bên dưới 
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Truy cập vào ngân hàng câu hỏi - Question bank, tùy chọn giá trị tại ô “Questions” 

sang giá trị “Import”. Tùy chọn “Moodle XML format” tại mục File format và tải lên tệp dữ 

liệu tại ô “Import question from file” và nhấn nút “Import” để tải lên tệp dữ liệu. 

 

Quá trình tải lên tệp dữ liệu sẽ được tiến hành và hiển thị kết quả số lượng câu hỏi đã 

tải lên. Nhấn vào nút “Continue” để hoàn tất các bước tải lên tệp dữ liệu. 
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Xem lại danh sách các câu hỏi đã thêm vào tại Question bank và Select a category 
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Danh mục bài tập điền câu trả lời ngắn 

Trong giao diện Question bank, tùy chọn danh mục câu hỏi tại ô “Select a category” 

 

Nhấn vào nút “Create a new question …” để lựa chọn loại câu hỏi cho danh mục câu 

hỏi trong khóa học. Trong hộp thoại tùy chọn dạng bài tập “Choose a question type to add”, 

Thầy/Cô tùy chọn “Short answer” và nhấn vào nút “Add” để khai báo thêm mới câu hỏi. 
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Tại giao diện Adding a short answer question, khai báo thông tin câu hỏi tại mục 

General: 

- Category: Vị trí danh mục câu hỏi. 

- Question name: Khai báo tên cho câu hỏi. 

- Question text: Khai báo nội dung câu hỏi. 

- Question status: Trạng thái câu hỏi (Ready - Sẵn sàng, Draft - Bản nháp). 

- Default mark: Điểm số mặc định cho câu hỏi. 

 

Tại mục Answers, khai báo đáp án đúng cho câu hỏi và tùy chỉnh tỷ lệ điểm tại ô 

“Grade”. Nếu có nhiều đáp án thì khai báo thêm các tùy chọn đáp án khác nhau tại các ô 

“Answer #” với # tương ứng với số lượng đáp án. 
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Kiểm tra lại các thông tin về nội dung câu hỏi và các đáp án, nhấn nút “Save changes” 

để lưu lại các thiết lập và khởi tạo câu hỏi. Tùy chọn Edit → Preview để xem qua mẫu câu hỏi 

vừa mới khởi tạo. 
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Lặp lại các thao tác trên để khởi tạo thêm nhiều câu hỏi hoặc có thể sử dụng biểu mẫu 

tệp dữ liệu có định dạng XML (.xml) để khởi tạo câu hỏi hàng loạt. 

 

Truy cập vào ngân hàng câu hỏi - Question bank, thay đổi giá trị ô “Questions” thành 

giá trị “Import”. Tại giao diện Import questions from file, tùy chọn giá tri “Moodle XML 

format” tại ô File format và tải lên tệp dữ liệu XML tại ô “Import questions from file” và 

nhấn vào nút “Import” để tải lên tệp dữ liệu đã chuẩn bị. 



25 
 

 

Quá trình thực thị tệp dữ liệu sẽ bắt đầu và hiển thị số lượng câu hỏi đã tải lên được. 

Nhấn nút “Continue” để hoàn tất quá trình tải lên tệp dữ liệu. 
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Xem lại danh sách các câu hỏi đã thêm tại Question bank và Select a category 
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Danh mục bài tập lựa chọn một hoặc nhiều đáp án 

Trong giao diện Question bank, tùy chọn danh mục câu hỏi tại ô “Select a category” 

 

Nhấn vào nút “Create a new question …” để lựa chọn loại câu hỏi cho danh mục câu 

hỏi trong khóa học. Trong hộp thoại tùy chọn dạng bài tập “Choose a question type to add”, 

Thầy/Cô tùy chọn “Multiple choice” và nhấn vào nút “Add” để khai báo thêm mới câu hỏi. 
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Tại giao diện Adding a Multiple choices question, khai báo thông tin câu hỏi tại mục 

General: 

- Category: Chỉ định vị trí danh mục câu hỏi. 

- Question name: Khai báo tên cho câu hỏi. 

- Question text: Khai báo nội dung câu hỏi. 

- Question status: Chỉ định trạng thái cho câu hỏi (Ready - Sẵn sàng, Draft - Bản nháp). 

- Default mark: Chỉ định điểm số mặc định cho câu hỏi. 

- One or multiple answers: Tùy chọn số lượng đáp án cho câu hỏi. 

- Number the choices: Kiểu ký tự bắt đầu cho các đáp án. 
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Tại mục Answers, thiết lập các đáp án và tỷ lệ điểm số, đánh giá cho đáp án đúng. 

 

Xem trước mẫu câu hỏi đã thêm bằng cách chọn Edit → Preview  
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Để cải thiện tốc độ thêm câu hỏi vào trong các danh mục câu hỏi cho khóa học, ngoài 

việc thêm thủ công bằng tay thì Thầy/Cô cũng có thể thêm từ tài liệu MS Word được chuẩn bị 

theo mẫu dưới đây.  

 

Hình 1: Biểu mẫu dùng để khai báo câu hỏi Multiple Choice 

Lưu ý, cần lưu ý các thông tin sau khi sử dụng biểu mẫu: 

- Sử dụng các ký tự in hoa (A, B, C, …) kèm dấu chấm để chỉ định các câu hỏi. 

- Khai báo đáp án đúng cho câu hỏi bằng cú pháp ANSWER: <đáp án đúng>.  

Kiểm tra lại các nội dung cho câu hỏi và đáp án, lưu lại tệp tin dưới dạng Plain text (.txt) 

bằng cách nhấn vào nút File → Save As. Tại hộp thoại Save As tùy chọn định dạng lưu trữ là 

Plain Text tại ô “Save as type”. 
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Sau khi nhấn Save, hộp thoại File Conversion xuất hiện. Trong giao diện hộp thoại, 

Thầy/Cô tùy chọn Orther encoding và tìm kiếm giá trị Unicode (UTF-8). Sau đó nhấn nút OK 

để lưu lại các thiết lập. 
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Tiếp theo, đứng tại giao diện khóa học. Thầy/Cô truy cập vào chức năng ngân hàng câu 

hỏi tại More → Question bank, thay đổi giá trị trong ô “Questions” thành giá trị “Import”. 
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 Trong giao diện Import questions from file, ngay tại mục File format Thầy/Cô tùy chọn 

giá trị “Aiken format”. 

 

Tại mục General, tùy chọn danh mục câu hỏi cần tải lên tệp câu hỏi đã chuẩn bị tại ô 

“Import category”. Ví dụ tại đây là tải lên tệp câu hỏi vào danh mục câu hỏi Exercise 5: 

Multiple Choice. 
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Trong mục Import questions from file, tải lên tệp câu hỏi đã chuẩn bị tại ô “Import”. 

Lưu ý: Tải lên tệp có định dạng Plain text (.txt). Sau đó nhấn nút “Import” để tải lên tệp câu 

hỏi đã chuẩn bị. 

 

Quá trình thêm các câu hỏi từ tệp tin Plain text (.txt) được thực thi, Thầy/Cô có thể xem 

được số lượng câu hỏi được thêm vào danh mục câu hỏi. Nhấn nút “Continue” để đi đến giao 

ngân hàng câu hỏi. 
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Có thể tùy chỉnh lại các câu hỏi đã thêm vào, biết được trạng thái, phiên bản của câu 

hỏi, số lần sử dụng cho các câu hỏi đã thêm trong danh mục câu hỏi. 
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Danh mục bài tập tự luận với Quiz 

Trong giao diện Question bank, tùy chọn danh mục câu hỏi tại ô “Select a category” 

 

Nhấn vào nút “Create a new question …” để lựa chọn loại câu hỏi cho danh mục câu 

hỏi trong khóa học. Trong hộp thoại tùy chọn dạng bài tập “Choose a question type to add”, 

Thầy/Cô tùy chọn “Essay” và nhấn vào nút “Add” để khai báo thêm mới câu hỏi. 
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Trong giao diện Adding an Essay question, khai báo thông tin câu hỏi tại mục General: 

- Category: Chỉ định vị trí danh mục câu hỏi. 

- Question name: Khai báo tên cho câu hỏi. 

- Question text: Khai báo nội dung cho câu hỏi. 

- Question status: Chỉ định trạng thái cho câu hỏi (Ready - Sẵn sàng, Draft - Bản nháp). 

- Default mark: Khai báo điểm số mặc định cho câu hỏi. 

 

Tại mục Response options, khai báo thiết lập giao diện làm bài cho bài tập. 

- Response format: Tùy chỉnh cách thức nhập dữ liệu cho bài tập. 

- Require text: Tùy chỉnh bắt buộc sinh viên phải nhập thông tin bài làm. 

- Input box size: Tùy chỉnh số lượng dòng dữ liệu. 

- Minimum word limit: Thiết lập số lượng ký tự tối thiểu. 

- Maximum word limit: Thiết lập số lượng ký tự tối đa. 

- Allow attachments: Thiết lập cho phép đính kèm tệp tin. 
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Kiểm tra lại các thông tin, nhấn vào nút “Save changes” để lưu lại các thiết lập và khởi 

tạo câu hỏi. Tùy chọn Edit → Preview để xem trước mẫu câu hỏi đã khởi tạo. 
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Lặp lại các bước trên đến tiến hành khởi tạo thêm các câu hỏi cho bài tập. 

 

 

 

 


